WP Car Rental Forum

You need to log in to create posts and topics.

Purchase - form slider image trouble

Hi, I purchased the theme, very clean, I enjoy it.

I only have one trouble, my pics in the background form on homepage don't resize or centered on tablet and smartphones.
Look perfect on WPBakery preview, on computer, but the pics are on the left on other devices.

Any solutions ? https://luxury-rentalcar.com.

Thanks.

Hello Pacosxm, Thank you.

Yes, best way would be to create diferent image for diferent sizes.  I would remove image background from the wpbakery row or theme settings, and add custom css.

This can be done on several ways;

  1. At page edition with wpbakery (top right gear)
  2. At theme options -> custom codes -> custom CSS
  3. At child theme style file

Css you would need to add is the following:

.custom_back{
background-position: center !important;
background-repeat: no-repeat !important;
background-size: cover !important;
}

@media screen and (max-width:768px){
.custom_back{
background-image:url('URLTOSMALLIMAGE');
}
}

@media screen and (min-width:769px){
.custom_back{
background-image:url('URLTOLARGEIMAGE');
}

}

Finally you will need to add the class custom_back to the row.

Hope it helps!

Thanks,
I understand all the first part : At page edition with wpbakery, etc...
I upload new images and change the URL in the CSS code

but I'm confused about :
“add the class custom_back to the row“ ???
how can I do that ?

Hello Pacosxm,

Im sorry for the late reply, for some reason we were not notified about your question.

You need to edit the visual composer row, and add the class "custom_back" at "Extra class name" field, which is located at the bottom of the options.

Please check the image below:

Edit row

Add extra class

Ok it works in another row (my fist on the homepage : “espace vide“, but I can find the row of the form...
I got nothing over the content of my page.
see what I got :